Jump to content
Sign in to follow this  
Sabre

Missing Addon menu

Recommended Posts

As the title says I have lost my Addon menu from the main menu bar in FSX. I now don't have access to Accu-feel, FS Recorder or FSUIPC

Has anybody come across this and more importantly anybody know how to fix it.

As always any help greatly appreciated.

Problem solved - I don't know why this works but I ran the FSUIPC4.exe again and whilst it said it was already installed correctly when I went back into FSX the "Addons" menu was back and I had access to the various addons.

Share this post


Link to post
Share on other sites

Hi Graeme,

It sounds like your dll.xml file has got corrupted?

Look in C:\Users\{USERNAME}\AppData\Roaming\Microsoft\FSX and open the file with Notepad.

Look for a section like:


<Launch.Addon>
<Name>A2A Feel</Name>
<Disabled>False</Disabled>
<Path>Modules\A2A_Feel.dll</Path>
<DllStartName>module_init</DllStartName>
<DllStopName>module_deinit</DllStopName>
</Launch.Addon>
<Launch.Addon>
<Name>AccuFeelMenu</Name>
<Disabled>False</Disabled>
<ManualLoad>False</ManualLoad>
<Path>Modules\AccuFeelMenu.dll</Path>
</Launch.Addon>

<Launch.Addon>
<Name>FSUIPC 4</Name>
<Disabled>False</Disabled>
<Path>Modules\FSUIPC4.dll</Path>
</Launch.Addon>
[/CODE]

If there's no entry here, or the file is non-existent then you won't see it in your add-on menu.

EDIT: I've attached my version for reference, if you have to rewrite yours then it should have most of the elements you need (File paths will be different) and for the ones that aren't on there just re-install and a new entry will be made by the installer.

Share this post


Link to post
Share on other sites

Hitting the "Alt" button once doesn't work to bring up the menu bar? Is it the whole toolbar or just the Addon buttton? If it's just the button, something might have got messed up in your dll.cfg file.

Share this post


Link to post
Share on other sites

Thanks for all the prompt input - problem solved - see above - sometimes I hate computers :stars:

Share this post


Link to post
Share on other sites

Glad you found the problem. I always get nervous when these things happen and I hate computers too. They do the darndest things out of the blue, like they ran out to the garage and forgot what they went out there to get.

I noticed that AH loaded a FSUIPC thingee along with the program itself. Was curious and I tried looking for it and can't seem to locate where it is. Would anyone be kind enough to tell me where it might be?(I run Vista)

Share this post


Link to post
Share on other sites

FSUIPC is normally under Modules in FSX folder and Add-ons in the FSX menu. AH usesFSUIPC to communicate does it not?

Thanks for the info, I have found it along witth a manuel and can now read up on it. Wasn't sure what it was when I read trough the AH book and typing FSUIPC in my search bar didn't show any folders or files come up in my laptop.

Aren't you going to duff-up Fodder for maligning Emily?

That cheating ho is with David now, so I'm done with her. What I'm worried about is, the guy I sent to rough up Fodder isn't answering his phone, so now I can't cancel the contract. :sorry:

:secret: Don't say anything or i'll end up having to pay for his hospital bills.

Share this post


Link to post
Share on other sites

I too am having add-on menu problems. dbs followme program. It was working great until about a week or so ago. Just disapeared along with the add on menu. I may have been the last set of updates that microsoft that I got which did it. I have deleted the follow-me program but stil do not ahve menu.

I have the entire tool bar but no add-on button. Here is my dil file. Any help would be appriciated. If I can get the menu back I will try to reload the program

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">

<Descr>Launch</Descr>

<Filename>dll.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>

<Launch.Addon>

<Name>Object Placement Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Mission Creation Kit

\object_placement.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Traffic Toolbox</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Traffic Toolbox SDK

\traffictoolbox.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Visual Effects Tool</Name>

<Disabled>True</Disabled>

<ManualLoad>False</ManualLoad>

<Path>..\Microsoft Flight Simulator X SDK\SDK\Environment Kit\Special Effects SDK

\visualfxtool.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>Reality XP GNS WAAS Hardware</Name>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Path>Modules\rxpGnsDriver.dll</Path>

</Launch.Addon>

<Launch.Addon>

<Name>FeelThere EJetX Helper</Name>

<Disabled>False</Disabled>

<Path>FeelThere\E170\EJetH.dll</Path>

</Launch.Addon>

</SimBase.Document>

s

Share this post


Link to post
Share on other sites

Hi Dick,

I have cleaned up the file and attached it to this post, back up your old one and replace this one to see if it helps, then re-install the follow me program.

Those MS updates can be a pain in the a.....!

Happy New Year.

Joe

Share this post


Link to post
Share on other sites

Joe, I installed it and there is still no add-on menu at all. Everything works good just no follow-me arrows when in dx10. Just got to figure out how to work around with air field diagrams and read taxi ways. Thanks for the help

Dick

Share this post


Link to post
Share on other sites

Dick, welcome to the site :welcomeani:

The progressive taxi arrows do not work in DX10 preview mode. It was not meant to be used full time that I know of and certain addon aircraft and other things will not work in that mode.

Share this post


Link to post
Share on other sites

Hi Dick,

That's bad news, what you could do is install FSUIPC which should at least bring the Addon menu item back?

Share this post


Link to post
Share on other sites

Hi Joe,

I don't have : Path>Modules\FSUIPC4.dll</Path> . At the chance Of sounding stupid I am not sure where I install FSUIP4 from. I have looked in all the folders of FSX and can not find a FSUIP4.exe file. Maybe you can ponit me in the right direction. Thanks

Dick

Share this post


Link to post
Share on other sites

Hi Dick,

There is no FSUIPC4.exe, what you should have in your Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules folder is a file called FSUIPC4.DLL

If you haven't, go to to http://www.schiratti.com/dowson.html and re-download it or here is a direct link http://fsuipc.simflight.com/beta/FSUIPC4.zip

Most people use the unregistered version, there should be installation instructions included.

Cheers,

Joe

Share this post


Link to post
Share on other sites

Joe thank a lot. I downloaded the FSUIPC4 and installedit. It put the information back in the DLL and the add on menue is back on the tool bar. I just hooked up my Saitiek X52 and loaded up the profile for my Carenado C 208 and everything seems to work great. Thanks for all your help and the help of the forum.

Dick

  • Like 1

Share this post


Link to post
Share on other sites

>>[2017 SOLVED]<<

i have win 10. Then after install fspassengersx my addon manager was lost completely. I found that my dll file was corrupted.

Then i use notepad++ to see if there's any deleted lines. At first sight, there is no problem.

But then i found a word under fsrecorder's session. </Launch.Addon> <Launch.Addon> (red means you have to delete the word)

as you can see, there are two tags. After i removed it, then addon manager back to normal. Contact me on (youtube: Dhanzow Deep) if you have any question

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×