Jump to content
johan

how to use 3 monitors with FSX

Recommended Posts

Hi All,

 

Does anybody know how to set up 3 monitors with FSX? I am using graphics card GeForce GTX1060 6gb.

 

Thanks,

Johan

Share this post


Link to post
Share on other sites

It makes no difference which simulator you are using, If your card has the appropriate connections, you are good to go. I have been using 3 monitors for years, FS9, FSX, and now P3D. you should have at least 2 DVI connections, and a few DP's on your card, so provided you have the correct cables, it's just a case of plugging them in and them setting them up in  the Control Panel , Display section , as to how you want them to show on your monitors.

 

Cheers

  • Thanks 1

Share this post


Link to post
Share on other sites

I use a Triple Head to Go for my 3 screens... but I've got a less meaty graphics card.  

 

Welcome to the 3-screen gang.. you won't be disappointed!!

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi hImim, my 3 monitors problem.

I have been using a Matrox Triple Head 2 Go digital edition,

Maybe It is possible to use it again with my.

 

new PC,

Window 10 , graphics card Geforce GTX 1060 .

I hope that you can help me , how to set it up,reg 

cables, connection , ect

                                                          Johan,

 

 

Share this post


Link to post
Share on other sites

Hi Johan

 

Its such a long time since i set it up, and i've kept Win7, so im not sure how much i can help, but the user guide is pretty straightforward. You need to make sure you have the  Matrox Power Desk SE software installed, and GXM from the disc that came with the hardware.

 

Make sure you follow the connection instructions for the cables as per the User Guide. One lead from the PC, then 1 lead from each of the ports in the TH2G to each monitor.

 

For me the Windoze settings were Display: 1 device on DVI, Res = 3072x768 and Orientation landscape.  That will give you one window across all 3 screens

In FSX, you don't use Windowed mode.. its 'Full Sreeen'

 

I found that i had to set the FSX .cfg of 'True Aspect Wide' from False to True or you feel like you're perched on the top of the control panel.. its way too close for comfort!

 

You can set up the Bevel adjustments by right clicking to open the Matrox Power Desk from the Icon in your System Tray

 

If you have already used it on another PC with a different Graphics card, it should just be a case of following those steps as laid out in the user guide on the disk. I had to play around with the display settings a bit but  3072x768 work.  I also had to make sure that my NVidia settings were set up to reflect the Windoze setting, and that the FSX program was recognised by it.

 

There will no doubt be some updates to the software for Win10 so you'll need to check the Matrox site for those, and any other software updates for Power Desk and SGU.  As mine is working perfectly, i don't want to mess about with new versions.. if it ain't broke, dont waste time phaffing!  :whis:

Edited by hlminx
  • Like 1

Share this post


Link to post
Share on other sites

Hi Johan, 

 

using three monitors is pretty easy these days. The 1060 GTA offers you plenty of options. You’ll need at least one DisplayPort adaptor if your monitors don’t support DisplayPort. To run three monitors, first plug all three in to gpu.

 

next start up the pc and open the NVIDIA control panel. Look for the option to configure NVIDIA surround. Click on this and follow the instructions for set up. You can even sort bezel correction here. Once done, click apply and you’re done. Run your flight sim and select the new resolution. 

 

Hope this helps

 

Jess B

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×