Jump to content
Sign in to follow this  

Solution to Ultimate Traffic claiming it's not registered

Recommended Posts

Hello Fellow Hangarians.


A couple of weeks back my installation of Ultimate Traffic 2 started acting up for me. Whenever I started FSX, or tried to run the configuration utility for UT2 it claimed it wasn't registered despite it having worked flawlessly since my computer upgrade in November.


Turns out Windows Defender had classified the .dll file (utii.dll) needed to confirm the registration as a Trojan and moved it to quarantine.


After several fruitless attempts over the last weeks to resolve the issue I finally managed to sort it out last night, and in case any one else in the community suffers from the same issue (or will suffer from it in the future) I thought I'd share my solution. The solution is based on you using Windows Defender as your anti-virus software. If not, you'll need to figure out to do the steps according to your installed Anti-Virus software, but the principle should be the same. Also, I'm running Windows 10, but the steps should be similar if you are running windows defender on older versions of Windows as well.


Step 1: Find your way to the installation path for UT2 within the main FSX/FSX:SE/P3D installation folder. I think it's in Flight1 Software/UT2, will double check that when I'm in front of my FSX computer later on tonight. Make sure that utii.dll is missing from that folder. If not, you're suffering from a different issue and will have to search on for a solution.


Step 2: Add your FSX/FSX:SE/P3D installation folder as an excluded folder that Windows Defender won't scan.
In windows 10 this is achieved by following these steps from microsofts guide.



Step 3: Restore utii.dll from Quarantine.

Follow the steps as explained here.



This step took several attempts for me before it worked. If the instance in quarantine containing utii.dll disappears from the list it has worked, and you can double check this by confirming that utii.dll is restored in the folder mentioned in step 1.


And then you should once again be able to get UT2 running and injecting traffic into your sim.

  • Like 2

Share this post

Link to post
Share on other sites

Thanks Micke, if you had this problem the chances are someone else will.

Share this post

Link to post
Share on other sites

Hey Micke, 

That must have been really irritating.

Glad you managed to sort it out though. 

I don't have UT so I am unable to comment.


Share this post

Link to post
Share on other sites

Actually I do have this problem. UT2 was fine until I had to reinstall Windows and FSX. Then found UT2 didn't want to come out to play and giving it's excuse as unregistered. I can't do it until the weekend, but will try what you have suggested. It sounds promising. Cheers.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this