Jump to content
MBunjes

next problem : sound

Recommended Posts

Hi,

 

After months of frustration and soul-searching my new build finally works satisfactory except for one detail : sound.

First I have to unplug and replug my yoke otherwise it's not recognized by windows and this reverts the sound device settings in FSX to default device.

Very irritating but as far as I know there's no solution.

What is worse however is the sound constantly fading out and in when I'm flying.

 

I use the on board Realtek sound chip from my motherboard.

The control panel sound settings show the Realtek speakers output as default sound device, and the communication device is set to do nothing.

In the PMDG fmc the sound device is also set to the Realtek Speakers option.

I have installed the directx_Jun2010_redist.exe as per advice from Ryan Maziarz of PMDG fame but no joy.

 

Does anyone have another idea I could try ?

Would a dedicated sound card make a difference ?

 

Thanks very much.

 

Martin

Share this post


Link to post
Share on other sites

Hi Martin,

 

I don't think a dedicated sound board will help, I have a Realtek chip on my board as well but have not experienced any sound issues. (I  don't have the 737NG by the way).

 

Have you tried looking in the the Windows Event Viewer after a problem? I may just give a pointer to where the problem is originating from, just type Event Viewer in your start button search.

 

Regards ... Joe

 

 

  

Share this post


Link to post
Share on other sites

Hi Martin,

This may be a dumb question but bear with me.

Have you installed the sound drivers from your motherboard disk?

It's just another shot in the dark.

 

I can not understand why this is happening for you. I have only ever set up my yoke once and it has worked fine since.

It certainly does not interact weirdly with my onboard sound device.

I feel this is going to be a tricky one to figure out, but good luck.

Brian

 

EDIT: Just another thought, make sure the yoke is plugged in to a USB2 port and not USB3.

Share this post


Link to post
Share on other sites

Yes, I installed the latest drivers from the Gigabyte website.

My former FS PC behaved exactly the same when starting up : the Saitek yoke was not recognized.

But the sound was ok and I never noticed whether it changed the device type in FSX.

While typing I get an inspiration : could it be a permission question ? I assume the sound device is somewhere in the FSX.cfg. Permissions could prohibit writing to the cfg file.

I'll look into it.

I have a lot of hardware connected (15 USB at the latest count) and it all behaves beautifully

I plug the yoke in the front USB2 port because I have to unplug and replug it all the time and I don't want to descent into the dark recesses under my desk.

 

Martin

Share this post


Link to post
Share on other sites

You have gone this way [below] to make your speakers default (green tick) and tested the sound.  Do you also do the same after you have connected the yoke to make sure the green tick is still there?

 

Connect the yoke to a on board USB and not through a powered hub as sometimes the generic hub does not read correctly and therefor corrupts.  I used to have the same problem with my Saitek Switch panel

 

until I connected to the computer USB and not the hub.  try it see how it goes..

W6NJ.jpg

Share this post


Link to post
Share on other sites

Hi I had the same kind of pb when installing my Pro Flight Saitek yoke. No ATC voice anymore and general sound volume going down.

I discovered that to solve it I had to declare in FSX parameters Sound which output I wanted to use (in both windows general sound and ATC voices). ( Realtek output speakers or my Logitech G35 headset speakers) The problem happens if I leave the "Default device".

 

Hope it helps...

Share this post


Link to post
Share on other sites

I have ATC on a different computer (Radar Contact) and it's fine. I tried all permutations in the FSX output options and it doesn't make any difference whether it's on default or Realtek speakers.

 

Share this post


Link to post
Share on other sites

it almost sound like your PTT is not set; and your mic is auto adjusting your sounds level

 

your best route at this point (personally i would have done long ago if i were you) is

grab another sound card; disable the onboard one and test to eliminate the possibility the onboard chip is for some reason defected

 

Share this post


Link to post
Share on other sites

You might have already tried it, but if not try deleting you FSX.cfg file and let FSX generate a new one (remember to back-up the current one though so you can easily restore it in case it doesn't help).

 

Also I found this via Google. According to this there could be issues if you have a 5.1 or 7.1 surround sound configuration when running FSX (again, not sure if this is the case for your setup). It claims it should work better with a Stereo speaker configuration...

Share this post


Link to post
Share on other sites

Hi Martin,

I have just been going through this with VoxATC.

What I had to do (via advice from RCSimulations) is, in FSUIPC map the space key to COM1 Transmit in key presses, then in the buttons and switches tab set the button on your controller that you wish to use to speak to be mapped to the space key.

I'm not on the PC at the moment, but when I am late on, I will take pics to show what I mean.

Bear with us mate, we will get it sorted for you one way or another.

Share this post


Link to post
Share on other sites

Thanks guys. I'll try deleting the fsx.cfg and see whether it makes a difference.

Also I'll look into the sound setup. I have a very old 5.1 setup connected. I'll replace it with a stereo setup and see what gives.

As I already said, there's no microphone in my set up so I don't think the PTT button could be the culprit.

 

Share this post


Link to post
Share on other sites

Well, rebuilding the fsx.cfg seems to have done the trick, although I'm not really able to test because of the next problem : USB

Share this post


Link to post
Share on other sites

So i finally managed to solve all issues and I'll post them for future reference :

 

The unrecognized yoke : connected this through a cheap powered usb hub and have had no problems since.

Sound : i finally managed to get the normal sound back in FSX. What I did was roll back the Realtek driver to the default Microsoft driver. This didn't work since the speakers were not seen as plugged in. I then reinstalled the Realtek driver via the "update driver" option in device manager.

It at first didn't recognize my speakers but after unplugging and reassigning the speakers it suddenly all sounded much better. I started up FSX and the PMDG and everything sounded as Microsoft and PMDG intended.

Very happy,

 

Martin

Share this post


Link to post
Share on other sites

Yippee! We're glad you are getting everything sorted out Martin.

This thread will, undoubtedly help others.

Congrats.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×